Acronis File Access Products: filenames corrupted after download using the Access Web Client
Symptoms
When downloading files as a .zip archive from Acronis Files Advanced on a localized (non-English) Windows 7 or Windows Server 2008R2 machine, the .zip file opens correctly using the native zip utility, however, the filenames are corrupted.
Cause
Certain Unicode characters are not interpreted properly by the OS.
Solution
Microsoft offers a hotfix to resolve the problem. Apply the hotfix.