Acronis Storage: Metadata Service Does Not Start Correctly on MDS Nodes
Symptoms
Acronis Storage Console is unavailable.
Cause
Master/slave roles assignment issue. The issue in the product is caused by the change of Hyper-V bus which might be caused by the host reboot.
Solution
Our development is working in the issue, the fix will be available in the nearest updates and this article will be updated accordingly.
As workaround, do the following to fix the issue:
Connect to Acronis_main node in Hyper-V:
- Switch to the shell environment: Alt+F2.
- Open the following file with "vi" /mnt/data/etc/netconfig.json
- Add parameter index:
"mds": {"iface": "<asasdasd>", ... "index": 0}}
//"index": 0 or 1 or 2 depending on the node number - Restart the node.
- Wait until the node is ready.
When the node is ready, connect to Acronis_Node_1. Repeat the steps described above with this node, only set the index to 1:
*,"index": 1}}
Then restart the node.
Connect to the other nodes one by one and set the subsequest numbers. Restart each node.
The console will become available in a few minutes.