Acronis Files Cloud: Client errors out with "Failed to receive handshake, SSL/TLS connection failed"
Symptoms
On a Windows 7 machine, Acronis Files Cloud fails to establish connection, with the following error:
RequestError: (35, 'schannel: failed to receive handshake, SSL/TLS connection failed')
Cause
This issue is related to disabling TLS 1.0 protocol due to security concerns during deployment of Acronis Cyber Cloud 7.9. Since TLS 1.0 was disabled but TLS 1.2 was not enabled by default on Windows 7, the machine cannot connect to datacenter.
Solution
Enable TLS 1.2 protocol on Windows 7 machine:
1) Open Windows Registry (Start -> Run -> regedit)
2) Create the following registry keys:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"DisabledByDefault"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
"DisabledByDefault"=dword:00000000
More information
Starting with January 2020, Microsoft, Apple, Google and Mozilla are planning to disable TLS1.1 by default. While Acronis Files Cloud supports connections over TLS1.1, we recommend to enable TLS1.2 right away, as described in the Solution section.
If you still need to enable TLS1.1, create the following registry keys.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
"DisabledByDefault"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
"DisabledByDefault"=dword:00000000
See also How to restrict the use of certain cryptographic algorithms and protocols in Schannel.dll on MS Support site.